Formatting in TextMaker

Post bug reports and suggestions for TextMaker 2008 for Linux.

Moderator: SoftMaker Team

Post Reply
runbei
Posts: 25
Joined: Fri Mar 17, 2006 4:17 am
Location: Mountain View, CA
Contact:

Formatting in TextMaker

Post by runbei » Mon Aug 17, 2009 11:43 pm

I just purchased SM 2008 Office for Linux. I'm having trouble with formatting on a document I'm editing for a client.

1. The first issue is that I don't find a simple line-spacing command in TextMaker. In Word, you can choose Select All and click icons for single, 1.5x, or double spacing or choose these options from Format > Paragraph. But in TM I only see the option Format > Paragraph > Line spacing, and then enter line spacing by points. That is very inefficient. Am I missing something? Is the feature hiding somewhere?

2. I run into a problem when I choose Select All, then Format > Paragraph > Line spacing, and set the spacing to 24pt (double-spacing for 12-pt text). Note: I have all text formatted justified.

The problem is that if I hit Enter twice to insert extra space between paragraphs, and then move the cursor to the end of the first paragraph and hit Delete twice to see what single-spacing looks like, TM insists on justifying the last line of the paragraph, even if it contains just 4-5 words, which makes the last line look bad, with very wide spacing between words.

3. In fact, I'm unable to delete the extra line I inserted between paragraphs. Pressing Delete or Backspace doesn't work.

4. Finally, I'm seeing some really terrible garbled text after some edits in TM with Track Changes turned on. I'm unable to reproduce the error to send a screenshot now, but will do so if it happens again. Generally, it goes like this: I'm editing with TC turned on but changes not showing. I press Backspace to delete some text, and TM deletes the entire remainder of the paragraph and inserts some kind of {field code} in curly brackets.
George Beinhorn
Mountain View, CA
http://www.writeremedy.com

pbk
Posts: 22
Joined: Fri Feb 23, 2007 8:37 am

Re: Formatting in TextMaker

Post by pbk » Tue Aug 18, 2009 9:57 am

runbei wrote:1. The first issue is that I don't find a simple line-spacing command in TextMaker. In Word, you can choose Select All and click icons for single, 1.5x, or double spacing or choose these options from Format > Paragraph. But in TM I only see the option Format > Paragraph > Line spacing, and then enter line spacing by points. That is very inefficient. Am I missing something? Is the feature hiding somewhere?
You can choose between different modes. Choose Auto an set it to 200 to get double line spacing (depending on the font size and font face, what is -- I think -- exactly what you need). If you chosse one of the other modes, you have to do the calculation by yourself.
runbei wrote:The problem is that if I hit Enter twice to insert extra space between paragraphs, and then move the cursor to the end of the first paragraph and hit Delete twice to see what single-spacing looks like, TM insists on justifying the last line of the paragraph, even if it contains just 4-5 words, which makes the last line look bad, with very wide spacing between words.
This is due to Word-compatibility. To switch the behavior Open File->Properties->View and hit the Compatiblity-Button and deactivate it.
runbei wrote:3. In fact, I'm unable to delete the extra line I inserted between paragraphs. Pressing Delete or Backspace doesn't work.
What extra line? Is "Track changes" active? If not, please attach a sample-document to reproduce this problem.
runbei wrote:Generally, it goes like this: I'm editing with TC turned on but changes not showing.
Tools->Changes->Show changes is active?

Jossi
Posts: 868
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Formatting in TextMaker

Post by Jossi » Tue Aug 18, 2009 9:43 pm

runbei wrote:1. The first issue is that I don't find a simple line-spacing command in TextMaker. In Word, you can choose Select All and click icons for single, 1.5x, or double spacing or choose these options from Format > Paragraph.
In TextMaker, you can add these icons to the toolbar via Tools :arrow2: Customize :arrow2: Toolbars.... The icons for "Single line spacing", "Line spacing 150%", and "Double line spacing" are in group "Format". Drag them into the toolbar and you can work in just the way you described for Word.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2815
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Formatting in TextMaker

Post by martin-k » Wed Aug 19, 2009 11:37 am

Also, for simple line spacing control, press Ctrl+1, Ctrl+5, Ctrl+2 for single, one-and-a-half, and double line spacing respectively.
Martin Kotulla
SoftMaker Software GmbH

ohna2s
Posts: 2
Joined: Mon Dec 21, 2009 6:33 am

Re: Formatting in TextMaker

Post by ohna2s » Mon Dec 21, 2009 6:40 am

How we can change the default measurement unit "inc" to "cm".
Because we are accustomed to using the unit cm.

Sorry my english bad

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7252
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Formatting in TextMaker

Post by sven-l » Mon Dec 21, 2009 9:01 am

ohna2s wrote:How we can change the default measurement unit "inc" to "cm".
Because we are accustomed to using the unit cm.

Sorry my english bad
Hello,

you need to change the regional settings in the control panel of your Windows. Set it to UK or another country that uses cm. SoftMaker Office uses the measurements from your regional settings.
Sven Leßmann
SoftMaker Software GmbH

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2815
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Formatting in TextMaker

Post by martin-k » Mon Dec 21, 2009 2:36 pm

sven-l wrote:
ohna2s wrote:How we can change the default measurement unit "inc" to "cm".
Because we are accustomed to using the unit cm.

Sorry my english bad
Hello,

you need to change the regional settings in the control panel of your Windows. Set it to UK or another country that uses cm. SoftMaker Office uses the measurements from your regional settings.
The customer posted in the Linux forum, so I assume he uses the Linux version of SoftMaker Office. Here, you have to go to Tools/Options in each program and set the measurement system to "Metric".
Martin Kotulla
SoftMaker Software GmbH

ohna2s
Posts: 2
Joined: Mon Dec 21, 2009 6:33 am

Re: Formatting in TextMaker

Post by ohna2s » Mon Dec 21, 2009 6:03 pm

thanks martin
yes, I use it on linux
I followed your instructions and successfully

thanks for the instructions you give to me

Post Reply

Return to “TextMaker 2008 for Linux”