Normal.tmv problem

Post bug reports and suggestions for the TextMaker 2008 for Pocket PCs beta software.

Moderator: SoftMaker Team

Post Reply
schild
Posts: 80
Joined: Wed Feb 27, 2008 5:55 pm

Normal.tmv problem

Post by schild » Tue Apr 01, 2008 6:57 pm

This is with the 2nd beta installed on my storage card. In textMaker I looked to see what the default folder for templates would be and it showed \My Documents\softmaker\templates. In file open when I selected the type as template. It didn’t show any. I then created what I wanted for my normal.tmv and using Save As, and template as the type I wanted, I saved it. I then closed TM and reopened it, but I didn’t use my new template. Using File Explorer I have a normal.tmv in \My Documents\softmaker\templates and \My Documents\softmaker\templates\english. It seems as if TM is saving and opening using the file path in the Tools|Options and creating new documents using a normal,tmv in a different path. When I select to create a new document it shows the \english folder to select the normal.tmv from. It seems like it should bee using the folder list in the Tools|Options.

amuehl
Posts: 231
Joined: Mon Aug 02, 2004 1:46 pm
Location: Nuremberg, Germany
Contact:

Re: Normal.tmv problem

Post by amuehl » Thu Apr 03, 2008 1:42 pm

Hello,

this has something to do with the preferences of your interface language. For example, if you have chosen an English UI and set as template folder \My Documents\softmaker\templates\ it will automatically user into the English template folder as English is your default UI language.

For example, if you change the UI language to Spanish (Espanol), TextMaker will automatically look in \My Documents\softmaker\templates\espanol for the templates.
Alexander Mühl
SoftMaker Software GmbH

schild
Posts: 80
Joined: Wed Feb 27, 2008 5:55 pm

Re: Normal.tmv problem

Post by schild » Thu Apr 03, 2008 1:56 pm

I realize that, but that is not what I see as a problem. I have English selected as my install language so the templates should be in the English sub folder of \My Documents\softmaker\templates. When I go to Save As and select TEMPLATE as the type, I think it should default to the ENGLISH subfolder. It is not, it shows Documents\softmaker\templates.

amuehl
Posts: 231
Joined: Mon Aug 02, 2004 1:46 pm
Location: Nuremberg, Germany
Contact:

Re: Normal.tmv problem

Post by amuehl » Tue Apr 08, 2008 5:24 pm

Hello,

in case of I want to save a template via save as and the template folder is set to \My Documents\softmaker\templates\English, TextMaker should switch exactly to this folder by choosing the template file format (.tmv). At least, that's the way it works for me.
Alexander Mühl
SoftMaker Software GmbH

schild
Posts: 80
Joined: Wed Feb 27, 2008 5:55 pm

Re: Normal.tmv problem

Post by schild » Tue Apr 08, 2008 6:18 pm

Let’s start with Removing and reinstalling TM. I did an English install to \StorageCard\Program Files\SoftMaker Office 2008.

When I open TM and go to the options it shows the Template folder as \My Documents\SoftMaker\Templates\.

Now let’s assume that I want to make a change to the normal.tmv. When I go to File|Open and set the type as a Template it shows no templates exist,

This because the install places them in \My Documents\SoftMaker\Templates\English as it should, but doesn’t set the Template folder in the Options. It should also set the Template folder in the options to \My Documents\SoftMaker\Templates\English.

amuehl
Posts: 231
Joined: Mon Aug 02, 2004 1:46 pm
Location: Nuremberg, Germany
Contact:

Re: Normal.tmv problem

Post by amuehl » Wed Apr 09, 2008 11:07 am

Ok, I have forwarded your question to our developers and will inform you as soon as I have news.
Alexander Mühl
SoftMaker Software GmbH

amuehl
Posts: 231
Joined: Mon Aug 02, 2004 1:46 pm
Location: Nuremberg, Germany
Contact:

Re: Normal.tmv problem

Post by amuehl » Wed Apr 09, 2008 2:24 pm

I've information from our developers: You can use templates for different languages. You are able to select templates from My Documents\SoftMaker\Templates\English or My Documents\SoftMaker\Templates\German. To be able to switch between templates in different languages, the default path is set to \My Documents\SoftMaker\Templates.
Alexander Mühl
SoftMaker Software GmbH

schild
Posts: 80
Joined: Wed Feb 27, 2008 5:55 pm

Re: Normal.tmv problem

Post by schild » Wed Apr 09, 2008 9:58 pm

This seems like it could be a problem if a user with a “little” knowledge types to change the normal.tmv. They may try to open it and think because it doesn’t show up in the default folder shown in the Options”, creates a new one and saves it (in the default folder; not English). Then they’ll be confused when the changes they made don’t work.

amuehl
Posts: 231
Joined: Mon Aug 02, 2004 1:46 pm
Location: Nuremberg, Germany
Contact:

Re: Normal.tmv problem

Post by amuehl » Thu Apr 10, 2008 8:37 am

I'll forward your feedback to our developers.
Alexander Mühl
SoftMaker Software GmbH

DrAT
Posts: 208
Joined: Sat Jul 23, 2005 11:37 pm
Location: West Midlands, UK

Re: Normal.tmv problem

Post by DrAT » Wed Apr 16, 2008 9:51 am

I agree that it could be confusing. I know where they are but if someone came to TM expecting it to function like Word, they might wonder where the templates were.
It's not easy to find them using the default PPC software either, unless you think to look in the 'English' sub-folder.
WM2003SE - HP iPAQ hx4700 - 64Mb RAM

WM5 - XDA Mini S

WM6 - HP iPAQ 214 - 128Mb RAM

WM6.5 - HTC HD2 - 448Mb RAM

StowAway BT Keyboard

Post Reply

Return to “TextMaker 2008 for Pocket PCs BETA”